Posts Tagged ‘1.9.2’

CentOS 6.5: Installing the Pagoda Client Ruby Gem

Saturday, June 21st, 2014

The common command to install the PagodaBox/GoPagoda Terminal Client:

gem install pagoda

On CentOS the error message should look about like this:

ERROR:  Error installing pagoda:
mime-types requires Ruby version >= 1.9.2.

One needs to obtain the installer script and execute it:

wget https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer
chmod +x ./rvm-installer && ./rvm-installer

Then one needs to reconnect in order to reload the path-spec.
Once rvm executable is within path-spec – one can update Ruby:

rvm install 1.9.2

This will first fetch and build ruby-2.1.2 and then ruby-1.9.2
May take quite a while – feel free to get some coffee.

Well, one should upgrade the installation to the latest version once:

rvm get head

The next attempt to install the pagoda gem:

gem install pagoda

Should succeed, because the dependencies are met:

Fetching: mime-types-2.3.gem (100%)
Successfully installed mime-types-2.3
Fetching: rest-client-1.6.7.gem (100%)
Successfully installed rest-client-1.6.7
Fetching: json_pure-1.8.1.gem (100%)
Successfully installed json_pure-1.8.1
Fetching: pagoda-client-0.2.2.gem (100%)
Successfully installed pagoda-client-0.2.2
Fetching: pagoda-tunnel-0.1.3.gem (100%)
Successfully installed pagoda-tunnel-0.1.3
Fetching: gli-2.0.0.gem (100%)
Successfully installed gli-2.0.0
Fetching: event_emitter-0.2.5.gem (100%)
Successfully installed event_emitter-0.2.5
Fetching: websocket-1.1.4.gem (100%)
Successfully installed websocket-1.1.4
Fetching: websocket-client-simple-0.2.0.gem (100%)
Successfully installed websocket-client-simple-0.2.0
Fetching: highline-1.6.21.gem (100%)
Successfully installed highline-1.6.21
Fetching: pagoda-0.7.8.gem (100%)
Successfully installed pagoda-0.7.8
Installing ri documentation for mime-types-2.3
Installing ri documentation for rest-client-1.6.7
Installing ri documentation for json_pure-1.8.1
Installing ri documentation for pagoda-client-0.2.2
Installing ri documentation for pagoda-tunnel-0.1.3
Installing ri documentation for gli-2.0.0
Installing ri documentation for event_emitter-0.2.5
Installing ri documentation for websocket-1.1.4
Installing ri documentation for websocket-client-simple-0.2.0
Installing ri documentation for highline-1.6.21
Installing ri documentation for pagoda-0.7.8
Done installing documentation for mime-types, rest-client, json_pure, pagoda-client, pagoda-tunnel, gli, event_emitter, websocket, websocket-client-simple, highline, pagoda after 6 seconds
11 gems installed